Under review

Can't login into the AddOn

EverHasi 3 years ago updated by sternber 2 years ago 20

I can't login for the EverSync addon, so I can't access the settings or synchronise the bookmarks in Firefox. It works fine with Chrome. Also the login for the webpage itself works. (Maybe interesting: in the last months the addon never sychronized with the first click on the icon, I always had to logout and login again.) On the extentions page I get only the short go-back message and a redirect to the login form.

EverSync version: 18.5.7

Firefox version: 76.0

Image 2387

Under review


Do you use Standard mode in Settings - 

I use "custom" (and I would not change this just to use one add-on), but for finding the bug: I tried to add the "moz-extension page" and the everhelper.me page as exceptions, did not work, then I switched the setting to "Custom" and restarted the browser. The button still shows the login option instead of the synch button. So I clicked login and got the page (in "logged in" status) like below (which is the described behaviour of the last months):

So I logged out and logged in again and got the "start synchronization" option within the button above – which leads to the "merge" option on the page (I assume because of the re-login just synch is not possible).

So it will be possible to synch bookmarks from time to time. But it will be some work, because I need to switch the settings and restart etc. Would be nice if you could find a solution where I can add just one side as exception instead of removing the whole security and spam protection as a whole.

But in the end I am happy to be able to use this tool. Thanks for that!

Ok, could you send screenshot of your custom settings?

I checked several options with the drop down in the first position, but the result is always the same.

… aaaand in English:

Did you try to unckeck Cookies block?

:-) That's the main point of the Firefox custom (security) settings: these settings are there to prevent tracking and spamming as good as possible. In special cases they may also help against phishing. It works pretty well.

If I use a page that I trust and that (for example) needs third party cookies, I add this page to the exceptions. – Like I said above: I tried to add "everhelper.me", but it did not work, maybe beacause the add-on settings are a mix of online and extension (browser local code) "website". I can't add the browser extension "page" (like "moz-extension://92220em…").

Its fine. I still can every now and then deactivate, restart, synch and activate again. I don't want to deactivate the spam and track protection in general just to be able to use the synch funtionality. And I don't expect you to rebuild the add-on to work with it. It is ok like it is.

First I added the sites to the exceptions next to "Enhanced Tracking Protection" (you need to call the page inside the browser and then manually deactivate on the left side inside the URL bar), but that didn't change a thing. Then I checked the developer console and saw that there are a lot of JS related errors because "https://everhelper.me" is blocked (third party…). That is strange, because there was the exception for the tracking protection as described above.

I checked again the settings and found the next part "Cookies and Site Data" also has an exception button. So I added everhelper there too, and now it works fine!

I consider this somehow a bug inside Firefox, because deactivating "Enhanced Tracking Protection" works without the exception inside the "Cookies and Site Data" section. But when I use the exceptions in the fist I need also the exception inside the latter (which seems to be a unrelated setting, but changes behaviour related to the first).

But: it works!

Thanks a lot!

June 20, 2021:  I'm having the same issue EverHasi reported last year.  I've added cookie exceptions for the links listed above, but I continue to only have the Login/Register buttons available, and clicking login takes me to my online account, but no sync options (again, as EverHasi captured above).

Thanks in advance.


Could we try anydesk.com ? We can't reproduce problem (

Pardon my ignorance, but what is anydesk.com?


It is remote access software. Our developer will connect and try to solve problem.

Don't know how comfortable I am with that, or how necessary.  This is what I'm seeing:

First, the login prompt:

When I hit Login, it gets to my account and says I'm online, but synchronization is not an option:


Could we try anydesk.com ? We can't reproduce problem.

What is it you'd be looking to do with anydesk?


Our developer will connect to you and try to solve problem.

So, this would be a live debug session where the developer would be able to see what's happening while I perform some activities?  I hope you can understand my hesitance to open my system's security.  When would this session be scheduled (I'm on the east coast of the US)?


I'm sorry, but I didn't see the alert. We can try Anydesk at any time convenient for you.

I appreciate your patience with me.  Unfortunately, due to my work schedule, there has been no good time to debug over the past month.  That being said, I've updated both Windows 10 and Firefox a couple of times since I first opened the ticket, and I'm now able to log in and synchronize properly.

So, it looks like the issue has resolved itself.  Again, my apologies for leaving this hanging for so long, but it least it has a happy ending.