+11
Under review

FVD does not directly open on first start of Firefox - a blank page comes first and remains

blunitya 7 months ago in FVD Speed Dial - FireFox • updated by American 1 month ago 32

Setting up FVD speed dial in Firefox as my start page as a custom URL in about:preferences#home; every time I launch Firefox, a blank page appears first. The FVD speed dial appears only when launching Firefox for a second time (by right-clicking the Firefox icon in the task bar, or by opening a new tab / clicking the home icon in the existing blank window). This has not always been the case in Firefox, but it has been an issue for me a few months now. The FVD speed dial in Chrome, on the other hand, works fine. I tried uninstalling the FVD speed dial Firefox add-in and reinstalling it again, but the situation remains the same.

+2

I am experiencing the same issue. Speed Dial is not displayed as the firefox start page.

I tried installing Firefox Developer Edition -- same story. The closest I could get to and FVD Startup is to choose Firefox Home (Default) as the Homepage and then clear all of the check boxes in the section Firefox Home Content in about:preferences#home. This will bring up FVD Speed Dial as the startup page albeit with a 2-4 second delay. The Home icon in the Menu Bar then becomes superfluous and can be removed. So to get back to the FVD Speed Dial, simply open a new tab :-)

Thanks for trying.... I'm tweaking things also with no luck. I don't think we should have to do this to make it work. Either it works or it doesn't. Hopefully either party fixes it with a new release.

Hello! What's your OS and browser version?

Can you send us your Firefox profiles?


Did you try to reinstall Firefox browser?

Hi

OS version 10.13.6

Firefox version 62.0

I tried to attach the FF profile. Hoping it comes through

I have reinstalled all

Ok, so it's MacOS 10.13.6.

Could you also show us what happens in Firefox Console when the problem happens: Cmd + Option + K


Make sure that you have this option turned on:



Hey thanks for the help

Hoping this is what you are looking forFF debug

Not exactly. We want you to open Console when you see blank page instead of Speed Dial. Show us Console when problem appears.

Right ....

Just launched FF after restart of system ... the cmd + opt + k

FF debug

The odd thing with this bug is - if I close and reopen FF it works fine.

It seems to happen only on the first open

So, only first Firefox launch after computer start? 

can we try team viewer session?

Should I reboot first , then you will take control ?

Yes. reboot and send me ID and pass

Send it to gleb.khegay@gmail.com to keep privacy.

Good morning ... I see a release of Speed Dial was installed. Initially it looks like the FireFox issue I was experiencing is resolved. If I see anything unusual I'll post here. Thanks for the fix.

Hi again - it worked only the one time. An initial launch of FF and speed dial appeared. Multiple launches after that only produces a blank screen. So I changed the start / home page on FF back to the standard FF start page. Now when I launch FF the FF start page appears but each time it is replaced by speed dial page on the same tab. It works but that's strange. Ray

Try the following:  Launch FIrefox new profile. Install only FVD Speed Dial and check it again.

Try the following:  Launch FIrefox new profile. Install only FVD Speed Dial and check it again.

I fixed my problem by:
1. uncheck the option "Show Speed Dial on startup" in the Speed Dial settings
2. restart Firefox
3. and then again open the Speed Dial options and again put the checkmark before "Show Speed Dial on startup".

4. The next time Firefox started, Speed Dial opened automatically, and the home button was also working properly.

Please disregard the above. It does not work again
....

Check Firefox settings for Home page options

Hi there,

is there any working solution about this issue ? I have same problem - MacOS 10.14.2, FF Quantum 64.0.2.

Under review

Hello

Yes, we will relelase fix soon

i have same problem for a while now.. win 7 x64, firefox quantum. I switched to different addon until this is fixed.

Please update the addon. If it doesn't work, le'ts try team viewer

Dear Gleb, Thank you!
I updated the add-on, and it's working well now.

Hello Gleb,

Thanks, it's working now for me too.

After updating to FF Quantum v65.0, it's again not working as before.

What problem do you have? What behavior do you expect?

Setting up FVD speed dial in Firefox as my start page as a Custom URL in about:preferences#home; every time I launch Firefox, a blank page appears first and remains.
However, when I choose the Firefox Home (Default) as the start page (clearing all the Firefox Home Content checkboxes) the FVD Speed Dial eventually appears by itself.
It would be nice if the "moz-extension://744b7e8b-c07e-40dd-ae8c-296bfd167935/newtab.html" as the Custom URL option would work. I would then be able to use the Home button in the ribbon to return to my FVD Speed Dial.

I'm having the same problem, and as described above, it happens on the first launch of Firefox after starting windows. After that if I close Firefox and open it again the Speed Dial page will load without problems.
Windows 7 - 64

Firefox 65.0.1

FVD Speed Dial (Up to date, sorry no idea where to check the version, but Firefox tells me there aren't any updates for my extensions)

https://imgur.com/NxH28IN

It just hangs there with the spinning (loading) animation.