0

FVD overrides restored tabs on start in Firefox

FrederickZh fa 3 anys actualitzat fa 3 anys 17

Environment:

System: Linux

Browser: Firefox 66.0b2

FVD: 68.6.7

How to reproduce:

  1. Open several websites
  2. Close entire Firefox (via close button or Ctrl-Q)
  3. Restart Firefox

Expected behaviour: The session is correctly restored and the website that I was browsing right before Firefox was closed is re-opened.


Actual behaviour: The last website is re-opened, but the tab is immediately redirected to FVD new tab page.


Additional info: I can reproduce this issue with FVD 68.6.3 and 68.6.7 but not in 67.6.9.

This also causes incorrect behaviour if one tries to open a link when Firefox is closed.

Make sure that this options is turned on:

It is turned on and everything works normally if I disable FVD. And I noticed that if I click on other tabs immediately after Firefox is started, those tabs are either redirected to new tab page or to some websites in my browsing history.

PS: just upgraded to FVD 68.7.3, same issue.

I'm using the same Firefox account on a Mac and everything is synced but I cannot reproduce the same issue on the Mac.

So I tried Help | Troubleshooting Information | Refresh Firefox Developer Edition to reset all settings of Firefox in Linux and the same problem just happened again... However if I create a new profile and install only FVD it's then all good.

I guess it's somehow an about:config setting that's persistent across 'refreshes' but I've got tons modified settings and completely no idea which one it might be.

Let's try Team Viewer session?

Hmm... ok but I'm gonna need a little while to get prepared for this...

Are you gonna try tweaking some of my configurations to see whether you could fix it or you simply want to know how exactly the issue is and the way to reproduce? If it's the latter one I can actually do a screen recording for you.

Yes, screen recording would be great!

I've done the recording but how I can share it to you securely? If you've got a GPG key pair I can simply encrypt the file and upload it here?

just upload it to google drive

May I know your email or is it possible to DM you the link here?

Yes. you can leave the link to your video here

gleb.test@mailinator.com

Just emailed you the link 👌

I'll send your video to our dev team and we'll try to find out where is the problem. I tried the same on Win 10 64 bit with Firefox and Firefox Developer Edition and everything works fine. Don't delete the video.

We've reviewed your video and now we are going to prepare test build for you.

Yup, the issue is gone in FVD 68.7.5! Thanks!