0

EverSync Add On not being recognized by Firefox 54.

Ather 4 years ago 0

Keeps saying I need to install it Can't merge Chrome with Firefox. Won't upgrade to Firefox 57.