+1
Under review

Show as a home page

Atsushi 4 years ago updated 4 years ago 2

Hello.


After Firefox had been updated to 62.0, Speed Dial can't be shown as a home page.

Before that, when I launch Firefox, Speed Dial was shown at first and immidiatery

and of course, I didn't change any settings.  Just FF updated.


Is this a problem of Firefox?

Is there somebody have same problem?

Under review

Hello


Strange. Can we try https://www.teamviewer.com/en/ ?

Thank you for reply and I could find a cause and solution by using "firefox -jsconsole" command.

The following is a starting log:


Bootstrapped manifest not allowed to use 'resource' directive. chrome.manifest:1
Bootstrapped manifest not allowed to use 'resource' directive. chrome.manifest:7
Bootstrapped manifest not allowed to use 'resource' directive. chrome.manifest:2
Logging system initialised at Mon Sep 17 2018 19:28:41 GMT+0900 common.js:206:17
Firefox Version: 62 firefox.js:52:5
NS_ERROR_FAILURE: Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIInterfaceRequestor.getInterface]
network-monitor.js:303
unreachable code after return statement storage.js:2225:24
Error: Invalid option asyncBlocking WebRequest.jsm:41:15
Start initial process Bookmarks.js:54:9
1. Check intergrity Bookmarks.js:61:13
Public-Key-Pins: サイトに使用されている証明書が既定のルート証明書ストアの証明書により発行されたものではありません。不慮の破損を防ぐため、指定されたヘッダーは無視されました。[詳細] https://profile.accounts.firefox.com/v1/profile">profile
2. Create guids if not created Bookmarks.js:85:13
Unchecked lastError value: Error: Could not establish connection. Receiving end does not exist. Speeddial.js:2557
portMessageProcess moz-extension://ae4cdbbc-8180-40d3-afd9-0b14a81131e3/eversync/js/Driver/Speeddial.js:2557:13

Unchecked lastError value: Error: Could not establish connection. Receiving end does not exist.
broadcaster.js:92
sendMessage moz-extension://ae4cdbbc-8180-40d3-afd9-0b14a81131e3/js/_external/broadcaster.js:92:7

Create guids for all finished! Bookmarks.js:92:15
Initial process finished Bookmarks.js:106:13


Sorry, some comments are in Japanese 'cause I'm a Japanese.

And the comment in Japanese says about root certificates.


A filtering software is installed in my PC and so I've changed "security.enterprise_roots.enabled" option to "true."

I've tried to change the switch back to "false" and restart FF, then your Speed Dial appeared!


In fact, when I tried other speed dial add-on, same problem occurred.

So this is not the problem of FF or add-ons.

Maybe the certificates from filtering service have some trouble.

(I've been using FF and your Speed Dial so long with "security.enterprise_roots.enabled = true".

This is the first time I faced the problem like this!!)


Thank you for your useful tool and caring users!