FVD downloads video and sound in two separated files mp4 and mp3 and I can't put then together

Geraldo CJr 5 months ago in FlashVideoDownloader • updated by Gleb Khegay 3 months ago 21

Sometimes FVD downloads the video into two separeted files: video in mp4 format and audio in mp3 format. I have tried use many tools to create a new video putting then together again, but I have not got. I have tried VirtualDub, FormatFactory and VLC, unsuccesfully. Thanks for any idea.

Same problem here.  But the free command-line tool ffmpeg can do the joining for you.  Google for the download site.

The parameters to use are:  ffmpeg -i _video.mp4 -i _audio.mp3 -c copy _media.mp4

Where _video.mp4 and _audio.mp3 are the files to be joined (muxed), and _media.mp4 is the resulting output file. 

Please, leave us the link to the video and tell you OS and browser version. It should work fine, but doesn't work on Windows XP and Vista

It happens on a large fraction of YouTube videos when I try to download at the highest resolution (those are the ones that stream video and audio separately, for reasons beyond my understanding).  Here's an example on which it happened recently:  (downloading 720p version):

I'm running Windows 10 x64 and Firefox 57.0.4 x64, with FVD v16.0.7, so it's definitely not due to legacy OS/browser issues.

I will note that (a) my internet connection is very congested, so downloads can take a long time, pause awhile, or occasionally fail, and (b) I often bulk-download *many* videos in quick succession, so there might be several dozens of large queued files (many Gb worth)... sometimes FVD even becomes unresponsive in that situation (after clicking "Download", the "Save As" dialog doesn't come up for a long time - 10's of seconds or a minute, even).  Not sure if this has anything to do with the failure-to-mux issue or not.

On an unrelated matter, I'm posting here using Google Chrome, because this forum site itself does not work for me in FireFox!

Here's a screenshot of how it appears in Firefox, with the developer console showing:

Hello! I've checked your link. It works well on my PC. Try to reinstall FVD module, firefox browser and fvd downloader. And may be your PC needs some cleaning from viruses.

I've tried to download some videos now (720p, 1080p, and even 4k). And everything is fine.

I already tried reinstalling both the FVD addon and the separate .msi module, and (after then restarting Firefox) it didn't help.  I'm quite sure I'm not suffering from viruses.  I don't want to reinstall FF, it's too much work to get it back to how I like it... So I guess I'll just wait and see if the next FF update fixes the problem.

I don't suppose FVD has a log file that might shed light on what's going wrong?

Not sure if it's relevant, but even though I downloaded and installed the "FVD Downloader Module", in the FVD settings I still see the "Download FVD Downloader Module" button.  Is that normal, or does it signify that FVD is somehow not detecting the module's installation?

I also notice that the _video.mp4 and _audio.mp3 streams do show up as regular FF downloads (plus the main file which, when muxing fails, just contains its own filename).  Again, is that normal, or does it mean they're being incorrectly downloaded by the browser instead of the downloader module?

Can we make teamviwer session?

No, absolutely not.  I'm not prepared to let anyone access my PC except me.  If you have specific things you want to check, ask me and I'll tell you.  Be as technical as you like: I'm a developer myself.

Ok. Let's do the following. Try to download smaller video. If video will not merge, try to play audio and video separately. 

Then launch ....\ffmpeg -i _video.mp4 -i _audio.mp3 -c cope out.mp4

You should use our ffmpeg and set the path to our ffmpeg.

Then post the results here.


Same problem here.  But the free command-line tool ffmpeg can do the joining for you.  Google for the download site.

The parameters to use are:  ffmpeg -i _video.mp4 -i _audio.mp3 -c copy _media.mp4

Where _video.mp4 and _audio.mp3 are the files to be joined (muxed), and _media.mp4 is the resulting output file

I re-tried the download of the same video at the URL I mentioned, and once again FVD left it un-muxed, in a temp folder in my \Downloads directory.

I then manually called "your" ffmpeg (located at C:\Users\<my user name>\AppData\Roaming\FVD Downloader Module), to do the muxing, and it worked fine:  It muxed the video & audio together exactly the same as "my" ffmpeg did.

So the problem does not appear to be with the version of ffmpeg that FVD comes with.

(BTW I'd note that the correct parameter is "-c copy", not "-c cope"... I assume that was just a typo in you post?)

It was code from our dev team.

Can you do something else?

Answer Allow connection after click on Debug

Ok, I did that, then cleared the console tab & re-tried the download.  Here's what came up in the console tab:

Right-hand pane is showing details for the "clickDownload" object.

If your code is actually calling ffmpeg with "-c cope" instead of "-c copy", that might be the problem.

Another observation:

If I hover over the FVD icon (so that the popup list is displayed) while the video downloads, I can see it get to 100%, and then it says "saving", but just stays that way.

If I move the mouse away and then re-open the list, it shows the file size again, and a "Cancel" button:  The UI clearly still thinks something is in progress.  Only closing the tab makes it go away.

It was misspelling from our programmer. We will make special build for you to trace the problem

Please, install this version: https://drive.google.com/file/d/1B1IRpaN0bpf0FRjuU7wV6bY6qWT2PzcO/view

Try to download file and send us results as TEXT, not screenshot. Send us whole text from console that you will get. Thank you.

Well, this is strange.  After installing the debug-version addon you supplied, downloads now mux correctly, BOTH with the debug version and with the original version (I had them both installed at the same time).  So I uninstalled the debug version, and restarted FireFox, to see if the problem would recur.  It didn't:  My downloads now appear to be muxing correctly.  Simply installing, using, and then uninstalling the .xpi you sent me seems to have fixed the problem.

Since no error occurred, there's not much point in me sending you console logs, as they'd only show normal operation.

Thanks with your help with this problem, though.  If it recurs I'll be sure to let you know, so you can hopefully pinpoint the cause for anyone else suffering from it.


Very glad that it works fine!