Under review

Nimbus screencapture for Firefox not working

Jorge Barba 5 years ago in Nimbus Capture - FireFox • updated by bestby 6 months ago 61
Hi, just installed Nimbus on Firefox 34.0.5. 

Basically, when I pick any option to capture it takes me to the screen where I can select tools from above; no button works.

Nothing happens when I click any button; even if I click done, nothing happens.


Maybe try http://www.teamviewer.com/ for check problem today?
sorry, wont be able to do that. here is another screenshot to show the problem: http://i.imgur.com/KJRzr8o.png i.e. if I click the arrow button the dropdown will open, but the default selected rectangle will remain selected, even after clicking the arrow button
http://i.imgur.com/K2MPP8F.png Heres the log output of the edit page on FF 34.0
http://pastebin.com/Lx8bSqVw and some more log entries including css logs in case it helps.
Please try to press on this button -http://nimb.ws/1nuTid After that you can draw arrow?
no, like i said it does not. I am 100% sure that this is a bug on the side of the extension and not because I am clicking incorrectly. I suspect your JS is not being loaded correctly on the edit page, probably due to some incompatiblilty with the new firefox version. I have tried clearing my firefox cache and temporary files, which did not help.
Same here, MacOSX Yosemite with Firefox 34.0.5
If I can Suggest also a small change, can you make a more "Fancy arrow" like the one on Skitch for example, and a better text, this will be amazing :D Cheers!
Fancy arrow? Can you send me screenshot of this arrow?
Of course. Those Graphics are made with Skitch from Evernote. It create those kinf of graphics and they are elegant in my opinion, will be good to have something like this, maybe little bit less "fat".

Text also is good how it works.

Same problem as Jorge

Hi, just installed Nimbus on Firefox 34.0.5.

Basically, when I pick any option to capture it takes me to the screen where I can select tools from above; no button works.

Nothing happens when I click any button; even if I click done, nothing happens.


Yes, we fixed problem and will upload update today.
Awesome!  Thanks for your awesome product also :)
We released new version of addon with fix of editor.
Awesome!  Confirmed, it's working on Firefox 34.0.5. :)
Confirmed it works, perfect, thank you!
Same problem with the new Firefox 43.0a2.

I can capture the entire page but the button "done" is not working. I can't save the image.

We fixed this problem and we are waiting approve by Mozilla team. But you can install new version from this link -

The fix does not work for me. I can capture the page, but none of the buttons work after that.
Please tell me your version of Firefox
It work for me until the moment i want to save it. The only option that work for me is copy to clipboard.
Please tell me version of your Firefox. Do you use Selected Area option?
I'm using 41.0.1 and I use Selected Area option.
Strange. I checked and it works fine. Problem with any site? Do you have problem on x2t.com for example?

I am unable to use on any site, including x2t.com.

Button just disappeared in Firefox 40.0.1...couldn't get it back. Updated to 40.0.2, reinstalled and the button still won't show up. This was the best capture for Nimbus Note and I'm really going to miss it.


Please tell me your OS. Can you send list of your installed addons to fvdmedia@gmail.com


I have the same problem.

After taking the screenshot, and after clicked on "Done" button, the "Save as Image" button doesn't work.

I use the latest versions:

Firefox 48.0.2
Nimbus 9.1.1


Please try to reinstall app for start.

Allready done that action. Clear even browser history but nothing changes.

It is strange. Maybe will try http://teamviewer.com/ tomorrow?

Sorry, I cannot do that.

I've tried even with AdBlock disabled. I don't know what else should I try. Tried with another similar extension, is working (Awesome Screenshot), but this one, no. Weird...

Both the OS and the browser are x64. Could be a problem ?

Windows 7 x64, Firefox 48.0.2 x64

We will check on Win 7, I have x64 too and it works fine.

1-2-17 I am using a Desktop running Windows 10 ... It does nothing for about the last couple of weeks or so nor a page over 10 Mb prior to it just quitting altogether...I liked the Nimbus Screenshot very much and now it looks as I will have to find another. I will check back now and then because I am loyal... I also have tried everything and am running all the latest versions of everything...One thing on occasion I do turn off RTC in FF which I know should have nothing to do with it... 17+ years Exp...Hope it gets fixed soon and Thank you


Can you send more details? Do you have problem only on big pager or on any pages? Can you describe problem?

I went and uninstalled the program and reinstalled it and it is work as it had before. I just call these Glitches, where you have, No explanation for why things are doing or not do things that they were with no apparent reason for them. I always start with a check for updates or frozen programs etc, then I Reboot which fixes a lot of Glitches.Microsoft is always turning my stuff back on like Xbox games and Cortana that I don't use. Something with a program must have change something like a Registry Entry or something. It is working Great Now but I have always had problems copying large pages with like over 10 MB in size, having 8 Megs and a fast i5 intel quad core CPU. I have about 22 TBs storage and keep my C Drive pretty Clear. I run a good VPN and have PeerBlock with Iblock, Malewarebytes Premium, Spybot Anti Beacon, DoNotSpy and some ad blocking for ads and FaceBook also a cookie blocker that will delete LSO and Zombie Cookies.

With all these things Nimbus has always worked Great. I have not since tried to do a large size page like 10MB yet but for weeks now it's working Great. Thank you Guys

Have W10, Firefox 51.0.1(32-bit). Nimbus 9.1.1

When I select 'entire page', it only captures the visible part of the page. I just tried to capture an email, (outlook) wanted whole page to bottom as was airline itinerary. Had to do this 3 times and put them together. I have tried other screen capture apps but they the same. And I have Nimbus on my 11in laptop which has been working great. Seems ok on other web page but not Outlook. This example is selecting, entire page, but as you see it only captures the visible part, in this case the middle.

on my 11in laptop which has been working great. - Works great on Outlook email?

I only use my laptop when traveling so not tried it on outlook lately. Can you confirm you can capture the entire outlook page?

We have this feature in Chrome version.

None of the screen capture programs work correctly through FF. I don't want to use IE or Chrome. The only issue I have is with Outlook which is through FF. Nimbus is still the best and I'll have to put up with my issue.


For a couple of weeks now I've noticed that Nimbus Screen Capture is not working correctly. If I select the nimbus capture add-on button, then select any of the capture options either nothing happens at all and the lists just stays visible on my screen (in firefox private mode) or the capture options menu disappears but nothing further happens:

There is the same reaction if i try to use Nimbus Screen Capture menu options avilable by right clicking anywhere on the firefox screen.

I am using Firefox Version 61.0.2 and Windows 10, Version 1803. I have tried uninstalling and reinstalling the Add-on, but the problem persists. Is it just me expereincing this problem, or has anyone else reported it as a general issue?

Thanks KB

Do you have same problem in non-incognito mode?

Sorry, just noticed your response.

The problem occurs in both incognito mode and non-incognito mode on firefox. But it manifests itself slightly differently in both:

Non-incognito mode - Select a capture option from the menu (e.g. Entire page or selected area). Menu disappears as if Nimbus capture is about to operate as normal, but nothing happens.The new tab showing the captured image and allowing further editing does not appear.

Incognito mode - Selecting a capture option from the menu has no effect at all. The graphic does not indicate the button has been depressed at all, the menu remains visible and nothing further happens.

Has anyone else reported any similar issues?

Do you have this problem on any site?

As far as I can tell. I've had the problem occur on every site I have tried. Mostly travel sites like SkyScanner, Trivago etc.

I have just noticed that Nimbus screen capture is now working again on non-incognito mode. Due to a new release:

However, this release does not seem to have been applied to incognito mode, so I still have the same problem there.



I have same problem in incognito mode - doesn't matter whitch site is open, Nimbus dialog open, but doesn't react. I can click on whatever I want, but it doesn't do anything. And dialog language is English, I'm from Czech republic, FF is in czech and in non-incognito mode Nimbus work and set language correctly. On the other hand in non-incognito mode Nimbus doesn't remember last path in PC where it saved file. It began about 2 weeks ago.

FF 62.0 64bit, W10Pro, build 1803, Nimbus version 14.3.5



Hi, I am also having the same problem. Firefox updated recently and since then the problems have started. Same issue: regardless of site, function buttons don't do anything. Thanks.


Do you mean Incognito mode too?

mine also doesn't work at all. every option just does nothing. haven't tried in incognito but it doesn't work in a regular firefox window for sure. i think it grays out the options in the drop down list slightly (i.e. it grays out whole page, selected area, etc.)

actually, i take it back, it might just be on tumblr